WordPress 5.5 Alert – Elementor Conflict

It has come to our attention that there are some known issues with Elementor Page Builder and the new WordPress 5.5 release. We will update this list, but currently, these are the known issues:
  • Pagination is not working on the 'Post' widget
  • The color picker is not working in the editor

If you have upgraded to 5.5 and are having issues with your website. Get in touch and we can guide you to the solution or provide a temporary fix until Elementor release an update. 

All our customers who have taken out our support packages do not need to worry, we will take care of this for you.

This conflict highlights the importance of taking a backup of your website before upgrading… it doesn’t happen as often as it used to but conflicts are always possible. If you turn on auto-updates, this is something worth thinking about.